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情報

Ver.21.0のWindows版Studioから初期状態がWebView2に変更となりました。


■概要

 ・Windows版Studioでは、Studio起動後のログイン画面の表示などにおいて、Microsoft社が提供するWebViewを使用しております。

 ・WebViewには下記2種類が存在します。

名前

レンダリング エンジン

Studioへの適用方法利用上の注意
WebViewIE11

Studio設定変更により適用可能


IE11ベースとなるため、ご利用環境によっては「Studioが正常に起動しない」などの

問題が生じる場合があります。

WebView2Microsoft Edge

初期状態で適用済

利用にはWebView2ランタイムが必要となります。別途インストールのうえご利用ください。


 ・現在は初期状態でWebView2が適用されるようになっております。

 ・WebViewはレンダリングエンジンがIE11となり、Microsoft社のサポートが終了しておりますので、WebView2への移行をお願いいたします。

 ・WebView2において、「Studioが正常に起動しない」「ログイン画面が表示されない」といった問題が発生した場合、下記をお試しください。

    - WebView2ランタイムの再インストール

    - Studioアプリケーションをアンインストールし、「現在のユーザー用にインストール(推奨)」を選択して再インストール

    


 ・また、WebView2の適用まで時間がかかる場合は、下記の手順に沿ってWebViewに切り替えることで、一時的に暫定利用可能です。


■WebViewへの切り替え手順


・Windows版Studioをインストール後そのまま起動するとWebView2となりますので、

  下記手順に従い、Studio設定ファイルを変更してWebViewへ切り替えます。


  1.Studio設定ファイルを開く

 ・下記ローカルディレクトリパスの設定ファイル(Studio.exe.config)を任意のテキストエディタで開きます。

コード ブロック
languagexml
themeDJango
%LOCALAPPDATA%\Programs\SkyVisualEditor17¥Studio.exe.config

 ※V17 のWindows 版Studio をインストールした場合の例となります。ご利用のStudioのメジャーバージョンに応じたディレクトリを参照ください。


 2.Studio設定ファイルの変更

 ・下記のように82 行目の「PortalBrowserType」のValueを0に変更することで、WebViewへ切り替えられます。

コード ブロック
languagexml
themeDJango
      <setting name="PortalBrowserType" serializeAs="String">
        <value>0</value>
      </setting>

※「1」の場合はWebView2となります。


 3. Studioの起動確認

 ・設定ファイル(Studio.exe.config)を上書き保存後、Windows 版Studio を起動すると、WebViewでご利用頂けます。利用可能かご確認ください。


■WebViewでStudioを起動するとエラーメッセージが表示される事象について


 ■事象概要

  ・WebViewでStudioアプリケーションを起動すると下記のように「ログイン画面でエラーメッセージが表示される」事象を検出しております。

  

 ■原因

  ・このエラーメッセージは、SkyVisualEditorサービスで使用しているGoogleTagManagerが、現在WebViewをサポートしていないことで発生しております。

 ■影響と解消策について

  ・本エラーが発生してもStudioサービスは正常にご利用いただけますので、ご安心ください。

  ・WebView2に移行いただくことで解消されますので、上述の通り、WebView2への移行をお試しください。