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【事象】

申請、承認、却下または取消をおこなう時、以下のエラーが発生する場合があります。

エラー:
項目自動更新で指定されている項目の更新に失敗しました。

【原因】

承認プロセス中に項目自動更新設定があり、なおかつ、更新される項目や更新される値の設定に問題がある場合、このエラーが発生します。

【回避策】

このエラーが発生した場合は、以下のいずれかに該当しないかご確認ください。

1. 選択リストに存在しない値を指定している

選択リストの値で項目自動更新を設定している場合、選択リストに存在しない値(または無効化している値)を指定しているとエラーが発生します。
更新する値が実際に選択リストに存在するかどうかご確認ください。

確認例:
[選択リストで選択可能な値を確認]
下図の例では、項目自動更新で使用している選択リストの値はABのみです。


[項目自動更新の設定を確認]
mitocoアプリケーション設定 > ワークフロー:承認プロセス管理 > 使用している「承認プロセス名」> 使用している「バージョン名」を参照して確認します。


項目自動更新設定の参照をクリックします。


更新する値Cになるよう指定している場合、選択リストに存在しない値のためエラーが発生します。

2. 項目レベルセキュリティの参照権限がない

項目自動更新で設定している項目に対してユーザに参照権限がない場合、エラーが発生します。
項目レベルセキュリティの設定から、エラーの発生しているユーザのプロファイルに項目のアクセス権があるかご確認ください。

確認例:
[項目自動更新の設定を確認]
項目自動更新の更新対象項目を確認します。下図の例では項目名「テキストボックス」を使用しています。


[項目レベルセキュリティの設定を確認]
オブジェクトマネージャ > ワークフローで使用しているオブジェクト > 項目とリレーション から項目自動更新で使用している項目(「テキストボックス」)を開きます。


項目の詳細画面から[項目レベルセキュリティの設定]をクリックします。


エラーの発生しているユーザのプロファイルが項目(「テキストボックス」)に対して、参照可能の権限が付与されているか確認します。

3. 入力規則を設定している

項目そのものに入力規則が設定されており、なおかつ、項目自動更新で指定している「更新する値」が入力規則に反している場合、エラーが発生します。

確認例:
[項目自動更新の設定を確認]
下図の例では、更新する値更新済みと入力するよう項目自動更新で指定しています。


[入力規則の設定を確認]
オブジェクトマネージャ > 使用しているオブジェクト >入力規則 から該当する項目を使用しているルール名の[編集]をクリックします。


項目自動更新で指定している値を入力規則で、入力できないようにしていないか確認します。
下図の例は、入力規則の数式で「更新済み」と入力できない数式が入っています。


入力規則のエラーメッセージについて

mitocoの項目自動更新は入力規則が原因であっても、入力規則で設定したエラーメッセージは表示されません。
表示されるメッセージは「項目自動更新で指定されている項目の更新に失敗しました」となりますのでご留意ください。



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