【事象】
mitocoカレンダーで関連先を検索しても、検索にヒットせず検索結果が得られないことがあります。
【原因】
Salesforceの高度なルックアップ検索が有効になっていないことが原因の可能性があります。
高度なルックアップ検索は設定によって、以下のように検索対象となる項目の範囲が異なるため、検索結果に違いが生じます。
- 有効になっていない場合:名前項目など、各オブジェクトの制限された項目セットが検索対象となります。
- 有効になっている場合:各オブジェクトのより多くの項目が検索対象となります。
【回避策】
Salesforceの高度なルックアップ検索を有効にして再度検索をお試しください。
高度なルックアップ検索を有効にする方法:
事前準備:Salesforce Lightningでお使いの場合のみ
SalesforceをLightningからClassicに切り替えるため、Salesforce画面右上のユーザアイコンをクリックし、表示されたメニューよりSalesforce Classic に切り替えをクリックします。
- Salesforceの設定をクリックします。
左上のクイック検索に検索設定と入力して検索し、検索設定画面を開きます。 この画面を少し下にスクロールするとルックアップ設定セクションがあります。
ルックアップ設定にて検索対象のオブジェクトの高度なルックアップ検索チェックボックスがオフ(無効)になっている場合は、これをオン(有効)にします。
(下図は取引先、取引先責任者に対して高度なルックアップ検索を有効にした例です。)設定を保存するため、画面最上部(または最下部)の[保存]をクリックします。
mitocoカレンダーの予定作成(編集)画面にて再度検索をお試しください。
高度なルックアップ検索が有効になっている場合、検索キーワード入力欄の下に検索対象の選択肢(名前またはすべての項目)が表示されるようになります。
注意:
・オブジェクトによっては検索対象を名前ではなくすべての項目に変更する必要があります。
・検索対象が参照項目として他のオブジェクトから引用している項目である場合、文字列検索の対象となりません。
関連記事:
- 検索ウインドウ内の「最近参照した<オブジェクト名>」「検索結果」に表示する項目を設定する方法につきましては、
カレンダー:関連先選択時の検索レイアウトの項目を変更する方法をご参照ください。 - Salesforceヘルプ記事:Salesforce Classic のルックアップ検索結果の設定
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