【事象】
Salesforce Classic環境において、mitoco V19にバージョンアップ後、システム管理者はmitoco Classicという名称のタブを開くことはできるが、一般ユーザからmitocoのタブが見えなくなった。
一般ユーザ:
従来、開くことができたmitocoタブが、
バージョンアップ後、見えなくなった。システム管理者:
バージョンアップ後、システム管理者のみ
mitoco Classicタブが存在している。
- Salesforce Classic環境において、画面右上のアプリケーションメニューよりmitocoを選択しても、一般ユーザがmitocoに遷移できなくなった。
【原因】
mitoco V19より以下の機能の追加、および既存機能の仕様変更を実施しております。
・LEX版mitocoタブを提供
・従来のmitocoタブの名称を、mitoco Classicタブへ変更
・LEX画面でLEX版mitocoタブとmitoco Classicタブが両方表示されないよう、mitoco Classicタブのアクセス権を変更この影響を受けて、一般ユーザがClassic画面にてmitoco Classicタブを利用するには、アクセス権の付与が必要となります。
なお、LEX画面にてLEX版mitocoタブを利用する手順については以下をご確認ください。
全般:V19にバージョンアップ後、Lightningのmitocoタブが表示されない
【解決方法】
ご利用中のSalesforce Classic環境で、以前のバージョンと同様のアクセス権をmitoco Classicタブに付与するには、システム管理者は、以下の設定を実施してください。
- Salesforceの 設定 > 権限セット を開きます。[新規]ボタンをクリックします。
表示ラベルとAPI参照名に任意の名前をつけ、[保存]をクリックします。
【作成例】表示ラベル:mitocoClassicタブへの権限を付与
API参照名:mitocoClassicTabPermSet- 次の2つの権限をこの権限セットに付与します。
(1) Visualforce(transTab)へのアクセス権限
1) 権限セットの一覧から、作成した権限セットを選択します。
2) アプリケーション画面が開きますので、Visualforce ページのアクセスを選択します。
3) [編集]ボタンをクリックします。
4) 利用可能な Visualforce ページ(左)からTSMNTBS.transTabを選択し、有効化された Visualforce ページ(右)に追加し、[保存]をクリックします。
(2) mitoco Classic タブへのアクセス権限
1) 権限セットの一覧から、作成した権限セットを選択します。
2) アプリケーション画面が開きますので、オブジェクト設定を選択します。
3) オブジェクト名の一覧からmitoco Classicを選択します。
4) [編集]ボタンをクリックして編集画面に入ります。
利用可、参照可能 2つともチェックを入れ、[保存]をクリックします。 - 当該権限セットの[割り当ての管理]ボタンをクリックし、この権限セットを使用するユーザを割り当てることで、以前のバージョンと同様のアクセス権を指定したユーザに付与することができます。
補足:
- 新規にmitocoをご利用になるユーザを追加する際には、mitocoの権限セットを合わせて上記で作成した権限セットも付与してください。
- この操作を実施すると、Salesforce Lightningの画面に切り替えた時、一般ユーザにLightning用mitocoタブが2つ表示されます(mitocoタブとmitoco Classicタブ)。
- Lightningで必要なmitocoタブのみ表示する際のシステム管理者による設定方法につきましては、全般:V19にバージョンアップ後、Lightningのmitocoタブが表示されない をご参照ください。