HttpRecoverableException

セールスフォースアダプタの処理でに失敗し、Read timed outというログが出力されている場合の対応方法について説明いたします。

メッセージの一例

com.appresso.ds.script.runtime.ComponentFailedException: [マスタ取得(クラウド/Salesforce/データ読み取り(クエリー))]の処理に失敗しました。原因:org.apache.commons.httpclient.HttpRecoverableException: java.net.SocketTimeoutException: Read timed out]

対象

セールスフォースアダプタ

原因

いくつかの原因が考えられます。

  1. データ量が多い、もしくは、クエリが遅い
  2. ネットワークもしくはセールスフォースのサーバー側の接続の問題

解決策

  1. データ量が多い、もしくは、クエリが遅い場合
    データの取得条件やセールスフォース側の設定を見直し、パフォーマンスチューニングを実施してください。

  2. ネットワークもしくはセールスフォースのサーバー側の接続の問題の場合
    リトライ設定を追加して、動作が再現するかを監視します。
    リトライ設定は、グローバルリソースで追加します。上記の例の場合、次のように設定します。。

    設定項目設定値
    例外クラス名org.apache.commons.httpclient.HttpRecoverableException
    エラーメッセージ

    java.net.SocketTimeoutException: Read timed out

    また例外クラス名を入力しないとエラーメッセージのみでリトライの判断しますので「Read timed out」をエラーメッセージ欄に入力していただくことでエラーメッセージに「Read timed out」を含むエラーはリトライを行なうという設定も可能です。
    詳細はヘルプの「アダプタ-クラウド-Salesforce-グローバルリソース」の接続リトライ詳細設定項をご参照ください。

     

 

 


テラスカイ管理番号 C-00006473