ConnectException: Connection timed out
セールスフォースとの連携に失敗し、ログにConnection timed out と出力されている場合について説明します。
メッセージの一例
java.net.ConnectException: Connection timed out
対象
Salesforceアダプタ、Salesforce Buldアダプタ、Salesforce Metadataアダプタ
原因
セールスフォースとの接続に失敗しています。
セールスフォースの接続先ホストとしては、主に次の2つがあります。
- ログイン時に使用する login.salesforce.com
- API操作に利用する [インスタンス名].salesforce.com (日本のデータセンターの場合、ap.salesforce.com)
このいずれかのホストとの接続に失敗したことを示しています。
解決策
第一にネットワーク経路上もしくは接続先ホストの混雑の問題の可能性があります。
その場合、グローバルリソースの「Connectionタイムアウト」の設定を延ばすことを検討してください。(デフォルトは5秒ですが、10~20秒程度に延ばして確認してみてください。)
また、login.salesforce.comへの接続に失敗している場合、ログインにもAPI操作用の接続先ホストを利用して状況を確認することも可能です。グローバルリソースの、ログイン先を「その他(直接指定)」とし、ログインURLに「https://ap.salesforce.com/services/Soap/u/23.0」などと入力することで実現できます。(URL末尾は既存のAPIバージョンです。)
しかしながら、ap.salesforce.com で常にログインするように変更すべきかどうかは、弊社では判断できかねます。つきましては、これでログインできる場合であっても障害回避の一時的な手段として使っていただくにとどめ、login.salesforce.comの回復を待って、設定を戻していただくことをお勧めいたします。
テラスカイ管理番号 C-00007503