Chatterアンサーの有効化をしたところ、デプロイができなくなった
Chatterアンサーを有効化したSalesforceの組織に、SkyVisualEditor Studioからデプロイしようとしたところ、デプロイができません。
メッセージの一例
- name:ChatterAnswersAuthProviderRegTest System.ListException: List index out of bounds: 0
- name:ChatterAnswersCreateAccountTest line -1, column -1: Previous load of class failed: bdcalcurate
対象
Chatterアンサーを有効化した際のデプロイエラー
原因
本件は、「Chatterアンサー」機能を有効化した際に、Salesforceから自動的に生成されるクラスに問題があったために発生する事象です。
解決策
解決策としては、以下をご確認ください。
- どのクラスでエラーが発生しているかを確認
- Salesforceの設定画面より、[開発]-[Apex クラス]をクリック
- Apexクラスの詳細ページ内の[すべてのテスト実行]ボタンをクリック
詳細は、以下のSalesforce社のヘルプをご覧ください。
https://help.salesforce.com/apex/HTViewHelpDoc?id=code_test_execution.htm&language=ja
- 該当のテストクラスの修正
以下は、ChatterAnswersCreateAccountTest クラスの修正方法に関するナレッジです。
https://help.salesforce.com/apex/HTViewSolution?id=000182219&language=ja
上記のテストクラス以外でエラーが発生する際は、Salesforce社のサポートまでお問合せいただけますよう、お願い申し上げます。
なお、本事象は2015年12月1日時点の情報です。
テラスカイ管理番号 C-00011236