エラーが発生してパッケージアップグレードができない

V11 以降のパッケージにてアップグレードをする際、メッセージ「このアプリケーションはアップグレードできません。」が表示され、アップグレードができない。
エラー詳細内容はお客様環境毎に異なる可能性がありますが、下記のようなエラーが表示されます。

 

対象

新しい元号「令和」に対応するために、お客様にてカスタムメタデータを追加している場合。
「本日日付」コンポーネントを利用し、且つ表示フォーマットが下記の何れかの場合は、新元号対応として登録頂いている可能性があります。

  • ggge年M月d日
  • ggge年M月

原因

V9 リリース時に 2019年5月1日 の改元対応として、新たな元号データをお客様自身でカスタムメタデータに登録いただける方法を紹介(/wiki/spaces/SVE4JA/pages/2950288)していました。しかし V11 パッケージ内に新元号のデータが含まれるため、パッケージのアップグレードをする際に、元号データが重複するためエラーが発生してしまいます。

解決策

解決策としては、お客様に登録いただいているカスタムメタデータを削除して頂いた後、再度アップグレード実施をお願いいたします。対応手順は下記となります。

  1. 管理者アカウントにて、該当Salesforce組織のカスタムメタデータ設定を削除
    • 設定 -> プラットフォームツール -> カスタムコード -> カスタムメタデータ型にアクセスし、表示ラベル「Era」の左横にある「レコードの管理」をクリック
       
    • 上記画像のように「era_name_1」以外のレコード登録されており、名前空間プレフィックスが「SkyEditor2」以外のレコードが存在していることを確認
    • アクション「削除」リンクよりレコードを削除
  2. パッケージのアップグレードインストールを再実施


※ 当対応での注意点

V11 パッケージに含まれる元号『令和』データの利用開始日である「Start Date」は『2019/05/01』が登録されています。仮に、お客様が登録したデータの「Start Date」が異なる場合は、和暦『令和』と表示される日付が異なる可能性があります。
(例:「Start Date」を『2019/07/01』としていた場合、6月中の表示は『平成』と表示されずに『令和』が表示されます)